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Loading System Architect 

, Double click on the System Architect icon 
to start the application, or find System 
Architect under the Start, Program Files, 
Popkin Software menus. 

 

 

The Audit Id 

If this is a fresh installation of System Architect 
then the Audit Id dialog will be displayed, 
otherwise the last Audit Id will be shown on the 
Status Bar. 

To modify the Audit Id shown on the Status Bar, 
select the Audit Id... option from the File menu. 

An ID of between 1 and 7 characters must be 
entered before the OK button becomes active. 

System Architect will attach the Audit Id to every 
item within the encyclopedia, identifying the last 
user to make a change. 

, Enter an Audit Id. 

 

Figure 1 Audit Id dialog 

) By default this is not a security feature, but may be used to restrict access to items within an 
encyclopedia that are ‘checked out’ to a particular Audit Id. 

System Architect will automatically open a Project Encyclopedia if it has been set to Load at Startup. 

Running System Architect for the First Time 

If no Project Encyclopedia has been set to load at 
startup, then the Encyclopedia Open dialog will 
be displayed with the Existing tab active.  This 
will indicate the last encyclopedia accessed, or 
the path that System Architect has been installed 
in. 

The Directory Tree can now be searched to 
locate an existing encyclopedia, or the Recent 
tab can be used to select previously opened 
encyclopedias. 

The New tab will allow new encyclopedias to be 
created. 

, Press the Cancel button to abort the 
opening of an encyclopedia. 

 

 

 

 

 

 

 

 

Figure 2 Encyclopedia Open dialog 
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System Architect Window Components 

 

Figure 3 The System Architect Window Components 

 

Title Bar A standard Title Bar displaying the application and the current encyclopedia path. 

Menu Bar A dockable object containing a familiar set of menu options.  Those ‘greyed out’ are 
currently unavailable. 

The Menu Bar can be docked down both sides and at the bottom of the application 
window, or left to float. 

) Access to the menu options may be made using the Alt key. 

Toolbars The dockable Toolbars provide fast access to some of the menu options.  The 
default Toolbars are; Main Toolbar, Diagram Toolbar, Edit Toolbar, and Symbol 
Style Toolbar.  The ‘greyed out’ buttons are currently unavailable. 

The Toolbars can be docked down both sides and at the bottom of the application 
window, or left to float. 

) Toolbars may also be created and customized. 

Status Bar Displays the name and location of a selected symbol as well as the current Audit Id. 

(Not shown in Figure 3) 

) If a number of users share a workstation, the Status Bar should be checked 
to ensure that an incorrect Audit Id is not used. 

 

, Maximize the System Architect window (if necessary.) 
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Creating a New Encyclopedia 

To open an existing encyclopedia, create a new encyclopedia, or to reopen the current encyclopedia, 
select the Open Encyclopedia... option from the File menu. 

Alternatively use the Open Encyclopedia... button  on the Main ToolBar. 

The Encyclopedia Open dialog will then be displayed. 

, Access the Encyclopedia Open dialog and click on the New tab. 

 

Figure 4 The Encyclopedia Open dialog - New tab. 

A path to the location of the New Encyclopedia may now be entered.  The Browse button may be used to 
search for an existing path and to create new subdirectories. 

) System Architect can create multi-level directories. 

The Load this project at startup checkbox may be used to store the encyclopedia path in the 
SA2001.ini file.  This encyclopedia will then automatically open the next time System Architect is started. 

, Create an FSA Course Project as shown in Figure 4 and ensure that it loads automatically next 
time System Architect is used. 

The Browse and Browse Detail windows should appear docked on the left edge of the Application 
Window. 

) Normally, when creating a new encyclopedia, it will be necessary to accept or modify its ‘Property 
Configuration’. 
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Selecting Diagrams and Property Sets 

System Architect provides support for a vast array of diagrams and methodology notations.  A Property 
Configuration dialog is provided that controls the diagrams and property sets that are made available 
within an encyclopedia. 

Customize Method Support 

To change the list of available diagrams, select the Customize Method Support option from the Tools 
menu and then select the Encyclopedia Configuration... option. 

 

 

Figure 5 The Property Configuration dialog set for FSA based Encyclopedias 

 

, Customize the current Encyclopedia to support the Methods and diagrams shown above. 

) If the Apply changes to all future encyclopedias checkbox is enabled, then the master 
SAdeclar.cfg file in the System Architect subdirectory will be changed as well as the copy in the 
encyclopedia’s subdirectory. 
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) Diagram and Property Set selections may be customized further by clicking on the Advanced... 
Command Button. 

 

Figure 6 - Configure Diagrams and Property Sets dialogue 

 

) Changes made to the current encyclopedia will not be implemented until it has been reopened. 

, Exit out of the dialogues by selecting OK and re-open the FSA Course encyclopedia 
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Enterprise Architecture Framework 

Framework Overview 

Over the last few years, users of System Architect have become more aware of the growing need to 
develop integrated models of their business in order to remain competitive and flexible to change.  To this 
end, interest in industry accepted Enterprise Architecture Frameworks has spiraled. Examples of these 
frameworks are: 

• The Zachman Framework  

• The DoDaf C4ISR Architecture Framework (C4ISR) 

• The Treasury Enterprise Architecture Framework (TEAF) 

• The Federal Enterprise Architecture Framework (FEAF) 

 

The implementation of a framework will: 

• 

• 

• 

• 

• 

• 

Provide a support structure for the modeling development 

Enhance users experience of the tool 

Increases buy in from senior management within the business 

Simplify some complexities of the tool by compartmentalizing items 

Enable a corporate branding of the tool 

Provide a focus for work effort 

 

To reduce the complexity and scope of developing and using an EA, it must be subdivided so that 
portions may be used independently or built incrementally in separate projects.  The FSA Enterprise 
Architecture Framework (FSA-EAF) subdivides its EA into three segments: 

• Focus:  A representation of a whole system from the perspective of a related set of 
concerns  

• Perspectives:  A Point of view of the overall EA representing a particular role or 
organizational entity 

• Work products:  Essential and supporting products required to be produced for the 
enterprise 

 

Review Figure 7 on the next page, FSA identifies resources and work products that provide direction for 
EA development, work products constituting the EA description, and work products documenting how to 
accomplishment an EA implementation.  This matrix like breakdown organizes the subdivisions of the EA 
description and demonstrates the relationships among them.   
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Figure 7 - Overview of EA Direction, Description, and Accomplishment
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Each cell in the Enterprise Architecture Framework represents the intersection of a particular focus and a 
perspective.  Each focus (the question what, how, where, who, when, and why) is depicted in a column 
and each perspective (point of view) in a row.  When you ask or answer a question, your point of view 
determines the kind of information contained in the answer.  It is the same with the perspectives in the 
Enterprise Architecture Framework.  The perspective determines the kind of information that will be 
recorded in a row and/or cell.  Without a proper perspective, information can never become knowledge.  
For example, eliminate any perspective or point of view from your mind and then try to describe “your 
network.”  What comes to mind?  It could be any number of things: your network of friends and business 
associates, the locations of your business, the topology of the cables, routers, etc. that  make up your 
LAN. 

You can’t describe your network in a useful way without a perspective.  The perspectives define the point 
of view or the level of abstraction for the information contained in the cell.  If you look across all of the 
cells in a single perspective, you will see all of the Enterprise’s knowledge from that perspective.  If the 
Framework is properly utilized the information and models within a single row will represent a complete 
description of the Enterprise from that perspective.   

At the same time, each column captures all of the Enterprise’s knowledge for the particular question 
being asked, i.e., the focus.  You build the total Enterprise knowledge for each focus by isolating each 
focus and defining the artifacts for each perspective within it. 

 

Figure 8 - FSA Matrix / Views and Perspectives 

 

The five perspectives translate into five levels of abstraction: 

• Scope 

• Enterprise Model 

• System Model 

• Technology Model 

• Components 
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When an EA description work product is shown within one cell of the FSA Matrix, it means that the main 
vantage points for developing that work product correspond to that column (view) and row (perspective).  
However, information from other views (and sometimes other perspectives) is needed to produce a work 
product.   

 

Figure 9 Views of the FSA Framework 

 

 

 

Figure 10 Perspectives of the FSA Framework 
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System Architect Framework Support 

Introduction 

To support the growing need of framework compliance, the System Architect Framework Browser has 
been developed to enable users to view and use both existing and user defined frameworks. User 
Defined frameworks are created through Userprop customizations and by using the System Architect 
Framework Editor. 

SA Framework Browser 

The System Architect Framework Browser is a utility that enables users of System Architect to view 
frameworks that have been developed using the System Architect Framework Editor. The following is an 
example of the FSA Framework interface that users can interact with in the System Architect 
environment. 

 

 

Figure 11 Example FSA Framework, created via the System Architect Framework Editor
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SA Framework Browser Interface Overview 

 

 

Figure 12 Framework Browser Overview Information
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How to use SA Framework Browser 

The framework browser is, in essence, a grid of buttons (cells) arranged in rows and columns.   Each 
button activates one or more browser(s) that display a focused subset of the diagrams and definitions 
contained within the default System Architect browser.  The particular diagrams and definitions displayed, 
depends on the definition of each cell.  More than one browser may launch if the cell contains items with 
different model perspectives. 

The browser of each cell acts in the same way as the default browser for System Architect.   

 

Figure 13 Typical Cell Browser 

 

Therefore, all actions that can be performed in the default browser are available to the individual cell 
browsers.   

For example: 

• 

• 

• 

Users can navigate the tree of diagrams / definitions by clicking on the plus sign to the left to the 
headings. 

Diagrams / definitions may be opened by a double click on the name or by drag and drop. 

By right clicking in the browser, the same floating menu is enabled, similar to the same action in 
the default System Architect browser. 

Most importantly, any changes made to the contents of the encyclopaedia are updated in the default 
browser on refresh. 
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Advanced Features 

Rows / Columns 

The SA Framework Browser also 
enables users to select entire 
columns, or rows.  This causes the 
display of a browser, which contains 
the accumulated content of all the 
individual cells contained within the 
column or row.   

Figure 14 FSA Framework 

Special Browsers 

System Architect’s browser contains a number of tabs, which delimits the view of the encyclopedia 
contents.  The Data Modeling and UML tabs are unique in that they also implement the concept of 
Models and Packages respectively.   

 

Figure 15 Multiple Browsers 

This functionality is enabled within the browsers 
presented within the SA Framework Browser.   

If a specific cell contains definitions that relate to 
Packages or Models, then the user will be 
presented with additional browsers. 
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The System Architect Browser 

When an encyclopedia opens the Browser will 
automatically appear, docked on the left hand 
side of the System Architect window. 

The Browser is normally made up of both the 
Browse and Browse Detail windows. 

Moving the Browser 

The Browser can be moved by selecting the title 
bar and dragging the browser to the desired 
location.  It may be dropped and left to float, or 
docked at the top, bottom or right edges of the 
System Architect window. 

Right clicking over the Title Bar will give access 
to available docking options. 

Resizing the Browser 

If the Browser is floating then its window may be 
resized by dragging its borders.  If it is docked, its 
free edge may be moved by selecting this edge 
and dragging to the desired size. 

Closing the Browser 

If the Browser is not being used it may be closed 
to leave more room for diagrams. 

The Browser option from the File menu or the 
Main ToolBar, or the  button can be used to 
close (or open) the Browser windows. 

, Close the Browser. 

 

Figure 16 The Browse window 

 

Figure 17 The Browse Detail window 
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Setting Preferences 

There are a number of automatic features, and a few control settings, that affect the way in which System 
Architect reacts during the creation and modification of diagrams. 

Preferences... 

Selecting the Preferences... option from 
the Tools menu, will display the 
Preferences dialog. 

During the initial stages of drawing a 
diagram, it may prove inconvenient to be 
prompted for the Associative Properties 
and Definitions of symbols. 

, Ensure that the Associate 
Checkbox is disabled. 

Most symbols will require a Name to give 
them an identity, and it makes sense to 
automate the naming of symbols. 

, Ensure that the Name and Define 
checkboxes are enabled  

) A name will be required before 
most symbols can be defined.. 

Figure 18 The Preferences dialog 

 

, Also ensure that the Simultaneous Select/Draw is disabled and the Immediate Auto-Routing is 
enabled. 

) The Save checkbox can be enabled to store any new changes in the SA2001.ini file, to establish 
them as defaults. 
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Working with Diagrams 

Diagrams are an important part of the encyclopedia, (though it is possible to populate the Data Dictionary 
without using diagrams).  System Architect supports the Creation, Saving, Closing and Deletion of any 
diagram that is currently selected in the Method Support. 

Creating a New Diagram 

To create a new diagram from the default 
browser, perform one of the following: 

• Select the New Diagram option from the File 
menu, 

• Select the New Diagram option from the 
Diagram toolbar, 

• Open the Browser, highlight the Diagrams 
option, right-click to access its floating menu 
and select New, 

• Drag the diagram icon and drop it over a blank 
area of the application window. 

, Create a Business Process Diagram 
and name it “Diagram 1” 

 

Figure 19 Browser’s Floating Menu 

The Select new type window. 

Either select a diagram type and press Enter or 
double-click an available Diagram Type and then 
enter an appropriate name. 

A diagram Name of between 1 and 80 characters 
can then be provided.  It may include spaces but 
it is wise to avoid non-alphabetic characters. 

The diagram name must be unique for each 
diagram type. 

) Names within System Architect are Case 
Sensitive. 

Figure 20 Select new type window 
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Diagrams, Symbols and Definitions 

Diagrams will normally contain Symbols.  Symbols may be named, and Definitions provided to describe 
them.  The properties in the definitions will depend upon the Method Support selected in the Property 
Configuration dialog. 

To understand the association between Diagrams, Symbols and Definitions: 

, Navigate back to Diagram 1 and set 
the mode on the draw tool bar by 
selecting the Event symbol.  Click in 
the white space of the diagram area to 
create an Event symbol. 

, Name the symbol “Account Inquiry”. 

) Symbol Names follow the same rules 
as Diagram Names. 

 

Figure 21 An Event Symbol 

, Create a new Elementary Business 
Process definition by right clicking 
Definitions in the Browser and 
selecting Elementary Business 
Process from the menu.                          
Assign “Retrieve Account 
Information” to the name field and 
close the definition.  

Figure 22 EBP Definition Creation 

 

  

 

Figure 23 EBP Definition Dialog 
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, Again set the mode on the draw toolbar by selecting the Process symbol and create a new 
Process. 

) It is possible to reuse the definition of “Retrieve Account Information” by clicking on the 
Choices... button and dragging it into the Name property text box. 

 

 

Figure 24 Drag and Drop Elementary Business Process Definition into Process Symbol Name 

 

) This behavior will only be present if the user has the following deselected in the ‘Preferences’ 
found under the Tools menu: 

• Allow In place name edit for symbols 
(unchecked)  

Figure 25 Preference  

 

 

, Save Diagram 1 and navigate back to the 
Framework Browser by selecting ‘Show Framework’ 
from the File Menu. 

 

Figure 26 Show Framework Selection 
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, Use the Framework Browser to create a new Process Flow Diagram named “Diagram 2”.  The 
diagram is created by clicking at the intersection of the “Enterprise Model” Row and the “Business 
Function”.  After depressing this button one or more browsers may appear. Each has been 
filtered for the cell the user activated in the framework.  Create the additional Process Flow 
Diagram and name it “Diagram 2”.  

 

 

 

Figure 27 Building Diagrams from the Framework 
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) The Browser windows from the framework 
should still be visible after diagram 
creation. 

, Use the open browse window from above 
to reuse the items created on the previous 
diagram. Drag and drop the Event and 
Elementary Business Process definitions 
onto Diagram 2 from the browser under 
the ‘Definition’ section. (Ctrl-click can be 
used to multi select items) 

 

Figure 28 Creating Symbols using Definitions 

 

, Close the browsers and Framework. (how do I close the framework window? Found how to 
minimuize it by right-clicking on child window title, selecting MDI Child As, and selecting 
Minimized) Select the Tile Horizontally option from the Window menu. 

 

Figure 29 Tile Diagrams Horizontal or Vertical 

 

, Click the Pointer in the toolbar to return to Select Mode and double-click on the Process symbol 
from Diagram 1 to display the Model Object – Elementary Business Process dialog. 
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, Click on the Related Requirements tab (if not active) and enter Requirement 1 in the Name 
column. Hit the enter key. 
 
Click on the Symbol tab and enter the Graphic Comment: This symbol has been defined. 
 
Click on the OK button to accept the Symbol Definition. 

) The changes to the EBP definition are saved to the Data Dictionary at this point, and when two 
symbols of the same type have the same name, they will share the same definition.  However 
detail on the Symbol tab of a definition will not be shared.  

) A Graphical Comment is also a displayable 
property and can be turned on or off 
through the ‘Display Mode’ options found 
when right clicking the appropriate symbol.  

 

Figure 30 Displayable Properties 

, Select either Process symbol on either diagram and modify its name. 

Edit the name of the EBP from “Retrieve Account Information” to “Access Account 
Information”. View the changes to the diagrams. 

Saving a Diagram 

To save the changes made to a diagram select the Save Diagram option from the File menu or the 
Diagram toolbar. 

If the diagram had been modified since the last save, a dialog requesting confirmation will be 
displayed.  This dialog will also appear when closing a diagram, closing an encyclopedia, or closing 
System Architect. 

, Save Diagram 1 and 2. 

) When a diagram is saved, the symbols contained on the diagram are saved.  It is possible to 
have created a definition for a symbol but not to have saved the symbol itself. 

The Save Diagram As... option in the File menu can be used to create a new diagram from the active 
diagram. 
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Closing a Diagram 

To close a diagram either select the 
Close Diagram option from the File menu, the 
Diagram toolbar or the diagram’s floating menu. 

) The floating menu may be accessed by 
right-clicking anywhere in white space on 
the diagram. 

, Close Diagram 2. 

) Unsaved changes to the diagram will 
cause the Save prompt to appear. 

 

Figure 31 A diagram’s Floating Menu 

 

Closing All Diagrams 

 

 

To close every open diagram select the 
Close All option from the Window menu. 

, Close all windows. 

 

 

Figure 32 The Window menu 
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Opening a Diagram 

Diagrams can be opened from the Browse 
window.  When the Browser is opened it 
refreshes its contents; displaying the All Methods 
tab and the Diagrams and Definitions groups. 

) If the Browser is open the Refresh option 
in its floating menu can be used to update 
the contents. 

 

The Diagrams branch of the Browser can be 
expanded to reveal a list of Types of diagrams 
that exist in the current encyclopedia. 

 

Figure 33 Using the Browser 

Each Type branch can then be expanded to 
reveal an alphabetical list of diagrams. 

 

 

Clicking on a diagram name within the list will 
normally display its picture in the Browse Detail 
window, however a textual description of the 
diagram could be displayed if preferred. 

 

Several diagrams may be selected at the same 
time by using Shift and Ctrl. 

 

 

Figure 34 Diagram Picture Detail 

 

 

Open 

Diagrams may be opened by using 
one of three methods: 

, Re-open Diagram 1. 

• Using the Open option in the floating menu. 

• By double-clicking on the diagram name. 

• By dragging the diagram name beyond the Browser. 
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Other Browser Options 

By accessing the Browser’s Floating Menu it is possible to; 

• Copy a selected definition 

• Delete a selected diagram or definition.  The item cannot be deleted if currently open. 

• Open diagrams and definitions in Read Only mode.  This option will open all selected diagrams and 
definitions in read-only mode.  This prevents the user from locking the items they open so others can 
still access the items for edit.  The user setting their browser into read-only mode will get read-only 
copies of the selected items they open after setting this option. 

• Display (or close) the Detail Window with the Details option. 

• Preview a diagram before opening it with Pictures.  A diagram’s description will be given, if Pictures 
are switched off.  Definitions are unaffected by the Pictures switch. 

• Provide Access Control and then Filter the Browser’s list. 

Access Control and Filters 

It is possible to maintain different access rights to items within an encyclopedia.  Items may be 
Checked Out to individual Audit Ids or Frozen.  This provides an effective mechanism for controlling 
access to diagrams and definitions within a multi-user environment. 

Check in/Check out Checked out items are accessible on a read only basis by other users, but 
the owner can modify and delete. 

Unlock locked item Allows a user to release a diagram or definition that has been locked within 
a network encyclopedia.  This will be due to an unusual termination of 
System Architect. 

Freeze/Unfreeze Allows access on a read only basis to all users.  Set by a Supervisor. 

) Access rights are limited to Check in, Check out and Unlock locked item, unless supervisory 
access has been granted. 

Checking Out a Diagram 

When one or more items have been selected 
within the Browser, the Access Control... option 
becomes active. 

Subordinate diagrams (Child Diagrams) and 
Subordinate definitions can be automatically 
checked out with the selected diagram(s). 

, Check out Diagram 2 along with any 
subordinate definitions. 

) The available actions will depend upon 
the current status of the item. 

 

Figure 35 Access Control dialog 
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A report will be displayed, giving detail of any 
changes made to the Data Dictionary. 

Any items that are checked out will now appear in 
the Browser, prefixed with a . 

 

, Access the Audit Id… option in the File 
menu; log on using a different Audit Id 
and then attempt to open both diagrams. 

 

Figure 36 Checked Out Diagram 

 

Filtering the Browser 

The Browser may now be filtered to display only items that meet certain Checked Out and Frozen criteria.   
Select the Filters... option from Browser’s floating menu and disable the Checked out by others 
checkbox. 

Referenced By 

To find out where a model object has been used throughout an encyclopedia, highlight the name of the 
diagram or definition in the browser, right click, and select Referenced By…  You will be presented with a 
hierarchical view of all diagrams and definitions that reference the selected object. 
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Data Import and Export 

System Architect supports a mechanism for text transfer between the definitions held in the encyclopedia 
and other software packages.  Two formats are supported, text and comma separated value (CSV).  The 
text format produces a text file containing the Name and Description properties of the definition.  The 
CSV format supports all properties of the definition. 

Dictionary Export 

When the Export Definitions... option from the 
Dictionary menu is selected, the following dialog 
is displayed; 

The File Name box determines where the output 
file will be placed.  The CSV format drop down 
list box allows for toggling between CSV and Text 
output.  The scrolling list allows for the selection 
of a Dictionary Type. 

The Select Name option filters the output to 
definitions that start with the characters entered. 

The Name Prefix / Suffix and Comment Prefix / 
Suffix are only used with Text Format Exports. 

Figure 37 Export Data dialog 

After the extraction has finished, a Draft Report is displayed showing the definitions that have been 
exported, with a count of the number exported. 
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Dictionary Import 

When the Import Definitions... option is selected, 
the following dialog is displayed. 

For the CSV Format import, four collision options are
provided: 

• Never replace existing definition. 

• Delete all fields then add new data.  This 
erases the record before replacing it and is 
used to recover space when definition 
properties have been deleted. 

• Update single fields when data 
supplied.  This only replaces the fields that 
have data supplied in the import file. 

• Update single fields - clear field if no 
data.  This replaces the fields that have 
data and erases fields if they are not 
supplied as part of the import.  Therefore, 
when the import file has two adjacent 
comma characters where the data would 
be (e.g., aaa, bbb, ddd has no data for field 
ccc.) 

Figure 38 Import Data dialog 

 

For the Text Format import, three options are provided:- 

• Never replace existing definition. 

• Replace description when data supplied.  This only replaces the Description when data is supplied 
in the import file. 

• Replace description - clear if no data.  This will erase any Descriptions that have no data.  In the 
example below, the description for name2 would be deleted. 

<<name1>> 
Description for name1 
<<name2>> 
<<name3>> 
Description for name3 

Following a Data Import the Tools menu Dictionary Update option should be run to ensure that all 
relationships between the data are correctly held within the encyclopedia: 

On live encyclopedias be sure to take a backup of the encyclopedia prior to running the Import command. 
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Encyclopedia Backup and Archiving 

Each network encyclopedia contains: 

• a relational database, consisting of two tables and some indexes; 

• one data file for each graphical diagram; 

• one windows metafile (WMF) for each graphical diagram; 

• four files that store the configuration of the encyclopedia; 

• a lock-file that stops two or more users having write access to the same diagram at the same time, to 
prevent update anomalies; and, optionally 

• one or more ‘style-sheets’; 

• one or more internal report (RPT) files; and 

• An Images folder for storing custom symbols. 

 

) Every encyclopedia contains, by name, the same files; only the data in the files is different.  For 
this reason you must never use Windows Explorer to move diagrams or definitions between 
encyclopedias, System Architect has a Merge/Extract utility for moving diagrams and definitions 
between encyclopedias.   

 

For backup purposes you may use Windows Explorer to copy an entire encyclopedia to a ‘clean’ directory 
by selecting the encyclopedia folder icon.  Your internal System Architect Administrator should manage 
this. 
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