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Drawing Techniques 

System Architect supports a number of different diagram types.  The drawing techniques used for 
creating many of these diagrams are the same. 

Symbol Types 

There are two groups of symbols; the Node Symbols and the Line Symbols.  They are enhanced by the 
addition of Annotation and Graphics. 

Node Symbols are normally connected together using Line Symbols. 

) Node symbol definitions are available for Drag & Drop through the Choices option of a diagram’s 
floating menu, Line symbols are not 

The Draw Toolbar 

The Draw Toolbar will normally appear docked under the other Toolbars, and display the symbols that are 
available to the diagram.  These symbols represent those specific to the diagram and more general 
Annotation symbols.  They may also be selected from the Draw menu. 

) Pointing to each of the Tools will display its name. 

The Draw Toolbar may be toggled on and off by right-clicking over the Menu Bar or any Toolbar and 
Clicking on the Draw option. 

The Conceptual Information 
Model Toolbar 

The Data Class Relation is an example 
of a Line symbol. 

The Data Class is the only Rectangular 
symbol apart from Annotation symbols. 

Text, Rectangle and Doc Block are all 
examples of Annotation symbols. 

 

Figure 1 The Conceptual Information Model Draw Toolbar 

 

Deselecting Symbol Drawing 

Once a symbol has been selected, it will normally remain selected until you either deselect it or select a 
different symbol.  To deselect symbol drawing; 

• Click on the Select Mode button in the Toolbar. 

• Click on the Select Mode option in the Draw menu. 

• Press Escape on the keyboard ensuring you have committed the symbol by pressing Enter. 
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Cursor Shapes 

Once a symbol has been selected, the cursor will change from an Arrow to a Pen with a shape attached.  
The shape reflects the type of symbol to be drawn: 

 

Select Pointer 

 

Node symbol 
 

Zoom In/Out 

 

Place Text 

 

Orthogonal Line symbol   

 
Place Picture 

 

Straight Line symbol   

 

Insert Line Segment 

 

Arc Line symbol   

 

Placing Node Symbols 

The technique used to place symbols is determined by the current setting of the Simultaneous 
Select/Draw option in Preferences.  If this option is disabled then simply clicking, whilst in Node Symbol 
Draw Mode, will place the symbol on the diagram.  If the option is enabled then the left mouse button 
must be held down until a rectangular outline appears. 

Naming the Symbol 

Once a symbol has been placed on the diagram it 
is likely that a name will be required. 

A default name will be provided depending upon 
the symbol being drawn. 

) The Enter key must be pressed to end 
the symbol naming mode. 

 

Figure 2 Entering a Symbol Name 

) The Symbol dialog will be displayed if the symbol is too small to support text and a default name 
will not be provided. 

) The Name will only be requested if the Auto Name option in the Preferences dialog is enabled, 
and the Allow Auto Name option in the Symbol Style dialog is also enabled. 

The name of any symbol must have between 1 and 80 characters.  Spaces can be included, but non-
alphabetic characters, other than the underscore, should be avoided. 

) Names are Case-Sensitive and must be unique for a given type of symbol.  However some 
symbols will be Keyed by other definition names to make them unique. 

) The Choices... button can be used to name symbols from existing definitions in the Data 
Dictionary, if the Symbol dialog is displayed.  The Browser will also allow existing symbol 
definitions to be dragged onto appropriate diagrams to create symbols. 
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Exercise 

, Create a new Conceptual 
Information Model Diagram, named 
FFEL Loan linked to a Data Area 
named Student & Partner Eligibility. 

, Place three Data Class symbols on 
the diagram; SCHOOL, 
COLLECTION AGENCY and FFEL 
LOAN. 

 Figure 3 Placed Symbols 

Drawing Line Symbols 

The technique used to draw Line symbols is determined by the current setting of the Simultaneous 
Select/Draw option in Preferences.  It is perhaps simpler to disable this option when drawing Line 
symbols. 

To draw a line simply click over one symbol, whilst in Line Symbol Draw Mode, and then point and click 
on another symbol.  (Don’t Drag.) 

) If the Simultaneous Select/Draw option is enabled then the left mouse button must be held down 
over the first symbol until an Attachment Handle appears. 

The Name of the Line Symbol will normally be requested.  The Associative properties will be determined 
by the type of Line Symbol used to draw the line. 

, Draw a Data Class Relation line named Collects, from COLLECTION AGENCY to FFEL 
LOAN. 

Changing Line Styles 

Select the Symbol Style submenu from the 
Format menu, and select the Line... option to 
display the Line Style dialog. 

When an option button is chosen, it will force any 
selected lines to that style.  Any new lines will 
also have the selected style. 

The Save box allows a Line Style to be saved as 
the new default for subsequent diagrams. 

) The Round Corners option affects only 
the Straight - orthogonal line style. 

, Change the Line Style to 
Straight - any orientation.  

Figure 4 The Line Style dialog 
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Line Routing 

The route of a Line can be controlled by 
introducing bendpoints.  This can be 
achieved by clicking before the line reaches 
a symbol. 

, Draw a Data Class Relation line 
named Applies for, from SCHOOL 
to FFEL LOAN, including at least 
one bendpoint. 

) A Double-click will cause a line 
symbol to terminate.  This is not 
permitted within some diagrams. Figure 5 Drawn Lines 

Inserting Bendpoints 

Lines can have additional bendpoints 
inserted, to allow the line to be manually 
re-routed. 

To insert a bendpoint select the 
Insert Line Segment option from either the 
Line’s Floating Menu, or the Format menu. 

, Insert a bendpoint into the Applies 
for Relation line. 

Figure 6 Inserting Bendpoint 

Selecting Symbols 

Symbols are selected by clicking over the 
symbol.  This will cause a set of Handles to 
appear around the symbol. 

A Node symbol has four corner handles that can 
be dragged to alter its size and four handles 
along its sides to alter its shape. 

) The symbol may automatically re-size 
when the View is changed! 

 

Figure 7 Selected Node Symbol 
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A Line symbol has handles at the endpoints of 
the line and at any bendpoints. 

If the line is connected to a symbol then an 
Attachment Handle is displayed at its endpoint.  
This appears as a black cross instead of a black 
square. 

Figure 8 Selected Line Symbol 

Finding Symbols 

In the middle of the Diagram Toolbar is the 
Find Symbol button (binoculars). 

If pressed it will provide an alphabetic listing of all 
the symbols in the diagram.  This list may be 
scrolled, or by starting to type the name go 
directly to a section of the list. 

Once a symbol name has been selected the Find 
button can be used to display the symbol. 

This is particularly useful for navigating around 
large diagrams, without the need to scroll the 
window or use the Zoom feature. 

 

Figure 9 Find Symbol dialog 

Selecting Multiple Symbols 

A number of methods can be employed in selecting more than one symbol; 

• Hold down the Shift key and simultaneously click on the required symbols.  Symbols may be 
selected and deselected using this method. 

• Press and hold down the right mouse button while simultaneously clicking the left button. 
Symbols may be selected and deselected using this method. 

• Pull down the Edit menu and click on Select All.  This selects all symbols on the diagram.  
Individual symbols may then be deselected where necessary. (F8). 

• A Click and Drag will create a dashed rectangular area.  All symbols contained within the 
area will be selected.  This option will cause any previously selected symbols to be 
deselected, and therefore can only be used once at a time. 

) Pressing the <Ctrl> key before using the Click and Drag option, prevents the accidental 
selection of an individual symbol or embedding symbol. 

Clicking in White Space on the diagram will deselect all symbols. 

 

Copyright © 2002    Popkin Software  



 System Architect FSA-EAF Course 
Drawing Techniques  7 

Moving Node Symbols 

Node symbols can be moved by dragging them while in Select Mode.  The 
cursor will then change to a hand shape.  During the move the symbol will be 
shown as a dashed rectangle and is only redrawn when dropped. 

Any lines connected to the symbol will obviously remain connected. 

, Move the FFEL LOAN symbol to a position below the SCHOOL 
symbol. 

 

Moving Line Symbols 

Any of the handles that appear when a line is selected can be dragged to a new location. 

The Attachment Handles can be dragged to a new position on the boundary of a symbol, or away 
from the boundary of one symbol and attached to another. 

, Tidy up the Applies for Relation line by adjusting the position of its handles. 

) The Format menu contains other options that will automatically re-route line symbols. 

Moving a Symbol Name 

When a line is selected, its name will also be highlighted.  The 
name can be dragged independently of the line, to a new 
location. 

, Reposition the Collects text. 

If the name is moved to a location that exceeds a given distance 
then a Remote Line can be drawn to the line to which it relates. 
This also applies to a Node symbol when its name is positioned 
outside. 

To enable the Remote Line option and to change its pen settings, 
select the Format menu, Diagram Style submenu then the 
Notation option. 

, Enable the Remote Line option and move the Applies 
for text away from its Relation line. 

) The Auto Preference Reposition Name only applies to 
manual repositioning of a line symbol. 

Figure 10 Remote Name 

Block Move 

When multiple symbols are selected, they can then be moved as a group, using the same procedure 
as for moving a single symbol.  When dragging the selected symbols the cursor will change to a hand 
with a rectangle, and the dashed rectangle will represent the outline of all the symbols being moved. 

) Symbols that are contained within other symbols will move when the larger symbol is moved. 
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Deleting Symbols 

While a symbol is selected it can be deleted by the use of the <Del> key, or by selecting the Delete 
option from the Edit menu.  If multiple symbols are to be deleted then a prompt for confirmation will be 
diaplayed. 

) If the last Symbol to use a Definition is deleted then the definition will also be deleted.  
Deleted Entities will have their Attribute definitions, and Relation Line symbols and definitions 
deleted. 

Cut, Copy and Paste 

The Edit menu supports the standard Cut, Copy and Paste options, 
and the Edit Toolbar contains familiar cut, copy and paste icons; 

) System Architect also supports the standard <Ctrl> key 
shortcuts. 

 

 

Figure 11 Cut, Copy, 
Paste & Undo 

Diagram Glossary  

In addition to Copy and Paste you may save a 
group of selected symbols to a Diagram Glossary 
file.  This file can then be opened with another 
diagram active and the saved symbols copied 
into that diagram. 

To save a group of selected symbols access the 
Tools menu and the Diagram Glossary 
submenu.  Select the Save As… option. The 
saved file will have a .dgx extension. 

To place the saved set of symbols in another 
diagram access the same menu – Tools, 
Diagram Glossary – but this time select the 
Open… option. 

An outline of the symbols will appear and you 
may position them anywhere on the diagram. 

 

Figure 12 Diagram Glossary submenu 
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Symbol Style Options 

System Architect provides a number of features that allow changes to be made to the appearance of 
symbols. 

To gain access to these features open 
the Symbol Format submenu from the 
Format menu. 

) If a symbol has not been 
selected then some options 
may be ‘greyed out’.  
(Symbol Style... will also be 
greyed out if multiple symbols 
have been selected.) 

 
 

Figure 13 Symbol Style submenu 

Text formatting and symbol color can 
also be adjusted using the Symbol Style 
Toolbar. 

Figure 14 Symbol Style Toolbar 

 
Pen... The thickness and color of the line used to draw a symbol may be changed. 

Line... This alters the style of any Line symbol that is subsequently drawn.  If any 
lines are currently selected then they too are altered. 

Font... This changes the text supported by the selected symbol.  If no symbol is 
selected then the default font for the session is changed.  All symbols using 
the default font will be redrawn using the new values. 

Text Position... This allows the justification of the text within a symbol to be changed. 

The position of a Node symbol’s Name and Graphic Comment can also be 
adjusted. 

Color... Color can be used to Fill selected symbols.  Color can also be applied to the 
Font and Pen used by selected symbols; these options are also available 
from Font Style and Pen Style dialogs. 

Text Display... This option affects all symbols on the diagram, and may be used to remove 
certain elements of the textual information. 

Symbol Style... This option can be used to set a symbol’s default style, and its acceptance of 
some of the automatic features enabled in the Preferences dialog. 

Command buttons are provided that give direct access to many of the other 
options mentioned above. 

, Change the Symbol Style for the FFEL LOAN Data Class to; a slightly thicker dark green Pen, a 
Bold 12pt Times New Roman dark green Font, Centered text and Fill with pale blue. 
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Symbol Style Dialog 

When a symbol is first drawn it will have its style 
determined by the default settings associated 
with that particular symbol. 

The style for every symbol can be different, but 
only one default style may exist for each type of 
symbol. 

It is possible to take elements of a symbol and 
Set them, to modify the current default style. 

, Set the Pen, Font, Text and Color Styles 
from the FFEL LOAN Data Class. 

, Place a new Data Class symbol named 
LENDER onto the diagram. 

 
Figure 15 Symbol Style dialog 

Style Sheets 

Any alterations made to the default Style Settings will be lost when the encyclopedia is closed, unless 
they are saved to a Format File, known as a Style Sheet.  System Architect will prompt to save the Style 
Settings, whilst the encyclopedia is closing, whenever changes have been made. 

Style Sheet options may be accessed by opening the Format 
File submenu from the Format menu. 

, To see the effect of the Impose option; modify the fill 
color of the SCHOOL symbol to light green and set it as 
the default color. 
 
Select the COLLECTION AGENCY symbol and then 
use the Impose option from the Format File submenu. 

 

Figure 16 Format File submenu 

Open... Any saved Style Sheet, from any encyclopedia, may be opened and the 
styles Imposed upon selected symbols.  If the Save checkbox is enabled, 
then this Style Sheet will be stored in the SA2001.ini file and opened as the 
default Style Sheet for all encyclopedias that do not contain an Autoexec.sty 
file. 

Save If a Style Sheet is currently open, then it is possible to Save changes to it. 

Save As... The Save As... option is used to save the Style Settings into a new file.  The 
default extension .sty will be appended to the filename.  If the default 
filename Autoexec is used then this will apply automatically to all users. 

Reset This option will reset the style settings back to the System Architect defaults, 
or back to the initial settings of the open Style Sheet. 

, Save the current Style Settings to a Format File named MyStyle.sty in the Course Encyclopedia 
folder. 
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Diagram Style Options 

System Architect provides a number of settings that allow changes to be made to the appearance of the 
current diagram. 

To gain access to these settings open the 
Diagram Style submenu from the Format menu. 

  

Figure 17 Diagram Style submenu 

 

Notation... The Notation dialog is primarily concerned with the display of Associative 
properties, but covers other features such as Notation Font and, as already 
seen, the Line to Remote Text option. 

Display Options... 

 

The Display Options dialog contains settings that switch diagram features on 
and off. 

Figure 18 Display Options dialog 

Grid & 
Reduced View... 

Changes can be made to the Symbol Grid and Line Grid settings as well as 
altering the Reduced View default scaling value. 

) The Symbol Grid and Line Grid settings are independant of the 
Show Grid in the Display Options. 

 

, Set the Display Options as shown in Figure 18. 
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Scaling the Display 

The View menu provides several options for 
altering the diagram’s scale. 

) Most of the Scaling options are also 
available from the diagram’s Floating 
Menu. 

 

Figure 19 The View menu 

Used Area Displays the entire diagram, scaled to fit the Diagram Window. 

Actual Size Displays the diagram as it will appear when printed (without scaling).  It is 
important to realise that scaling may cause subtle differences between 
viewed and printed output. 

Reduced 69% This reduces the screen display by the percentage shown on the menu. 
(The default value is 75% but may be altered in the Grid & Reduced View 
Settings dialog). 

Full Page Scales to display a Full Page of the diagram on the screen.  This will depend 
on the current page size and orientation. 

Used Pages Displays all Pages that contain symbols.  Similar to Used Area, except that 
blank areas of pages will be included. 

All Pages Displays the entire drawing area; approximately 150 cms * 160 cms. 

) The Maximum Drawing Area can be altered within SA2001.ini 

Last View Toggles between the last two selected views. 

Zoom 
Also available on the Toolbar, the pointer will change to a Magnifying Glass, indicating 
zoom mode.  To Zoom In on a section of your diagram; press the left mouse button, to 
Zoom Out press the right mouse button.  You may also select an area to zoom in on 
by holding down the left mouse button and dragging the magnifying  glass over the 
desired area. 

 

The Toolbar buttons Zoom In and Zoom Out may also be used to make slight 
adjustments to the scale.  

Redraw 
Occasionally it is useful to redraw the diagram! 
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Exercise 

, Set the Pen, Font, Text and Color styles for the all data class symbols, based upon FFEL LOAN. 
 
Save, and then Reset the Format File. 
 
Select all symbols on the diagram and impose the symbol formats. 

, Consider the consequences of Imposing styles upon symbols. 

, Open the MyStyle.sty Format File and ensure that the Save checkbox is enabled. 
 
Select all symbols on the diagram and impose the symbol formats. 

, Add a data Class Relation Line from LENDER to FFEL LOAN named Provides. 
 
Change the Line style for all lines to Straight- orthogonal. 

LENDER

COLLECTION AGENCY

FFEL LOAN SCHOOL

Provides

Applies for

Collects

 

Figure 20 Completed Exercise 

 

Complete the diagram as shown in Figure 20. 
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